We have successfully resolved the technical issues affecting XenDirect client addresses. We will still continue to monitor the issue, but will close this incident.
If you are still experiencing any issues, please submit a support ticket with the details.
Thank you for your patience while we worked to get things back on track.
Posted Mar 19, 2026 - 06:26 EDT
Monitoring
A fix has been implemented for the missing Client address fields. We are monitoring the situation. Please let us know if you experience any issues with this fix.
Thank you for your patience. We apologize for the inconvenience.
Posted Mar 18, 2026 - 05:37 EDT
Update
We have created a fix for the client address field issue, but the attempt to deploy that fix last evening was not successful. The programming team are working on an alternative. If a resolution is ready, there is the possibility we would deploy during normal working hours. We know that disrupts users, so we will make that decision carefully. Otherwise, the fix will be scheduled to deploy early Wednesday morning, March 18.
We apologize for the inconvenience and hope to get everything up and running soon.
Posted Mar 17, 2026 - 08:37 EDT
Update
We continue to work on the issue and will notify you when the fix is deployed.
Thank you for your patience while we resolve the issue.
Posted Mar 16, 2026 - 13:11 EDT
Identified
We have identified the issue and are in the process of correcting it. That will take a reboot of the servers which will happen at 8:50 AM ET (less than 10 minutes from now)
We apologize for the inconvenience and hope to get everything up and running soon.
Posted Mar 16, 2026 - 08:42 EDT
Investigating
There are numerous reports that users are unable to add Client addresses as the fields are missing from the form. We’re aware of this issue and are working to fix it. We’ll share updates as soon as we learn more. We apologize for the inconvenience and hope to get everything up and running soon.
Posted Mar 16, 2026 - 08:29 EDT
This incident affected: XenDirect Admninistrative Portal.