The rollback process was completed and we have monitored successfully.
We will now close this incident. The release upgrade will be reviewed and rescheduled.
Posted Aug 19, 2026 - 08:31 EDT
Monitoring
The release roll back is complete and Add Assignment is working as expected. We are monitoring the situation.
The release upgrade will be reviewed and rescheduled.
Thank you for your patience. We apologize for the inconvenience.
Posted Aug 19, 2026 - 07:31 EDT
Identified
The roll back process has started.
We apologize for the inconvenience and hope to get everything up and running soon.
Posted Aug 19, 2026 - 07:03 EDT
Investigating
After testing, an issue has been discovered related to Add Assignment in the release deployment this morning (8/19/26). Given the location of the issue and the peak registration efforts of many users, we are rolling back today's release upgrade back to release 3.07.07.06. This should be completed by or before 8:00 AM ET.
Thank you for your patience while we perform the roll back process.